use strict;
my $str = 'IT&&faculty(\'Mousum handique\'|\'Abhijit biswas\'|\'Arnab paul\'|\'Bhagaban swain\')
Mousum handique(designation|address|phone number|\'IT Assistant professor\'|<AUS staff quaters>|#5566778899#)
Abhijit biswas(designation|address|phone number|\'IT Assistant professor\'|<AUW staff quaters>|#5566778891#)
Arnab paul(designation|address|phone number|\'IT Assistant professor\'|<AUE staff quaters>|#5566778890#)
Bhagaban swain(designation|address|phone number|\'IT Assistant professor\'|<AUW staff quarters>|#5566778892#)';
my $regex = qr/(?m)^\s*([^\(]+)\([^\)]*\|<([^>]*)>[^\)]*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}