re = /(?m)^\s*([^\(]+)\([^\)]*\|<([^>]*)>[^\)]*\)/m
str = 'IT&&faculty(\'Mousum handique\'|\'Abhijit biswas\'|\'Arnab paul\'|\'Bhagaban swain\')
Mousum handique(designation|address|phone number|\'IT Assistant professor\'|<AUS staff quaters>|#5566778899#)
Abhijit biswas(designation|address|phone number|\'IT Assistant professor\'|<AUW staff quaters>|#5566778891#)
Arnab paul(designation|address|phone number|\'IT Assistant professor\'|<AUE staff quaters>|#5566778890#)
Bhagaban swain(designation|address|phone number|\'IT Assistant professor\'|<AUW staff quarters>|#5566778892#)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end