const regex = new RegExp('^(?:(?!\\/p).)*<p>(?:(?!\\/p).)*\\[callout\\](.*?)\\[\\/callout\\].*?<\\/p>(?:[^<>]*<p>.*?<\\/p>){2}[^<]*\\K', 'gs')
const str = `<p>If you wanna improve yer German, don't try to read Heine or some elevated crap... watch old episodes of [callout]Tatort or Bukow & Konig[/callout].</p>
<p>If I were teaching a music appreciation I wouldn't teach Beethoven. I'd teach Stamitz and average composers.</p>
<p>And here is a 3rd paragraph.</p>
<p>And here is a 4th paragraph.</p>`;
const subst = `<blockquote class="pullquote">\1</blockquote>\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);