# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?!\/p).)*<p>(?:(?!\/p).)*\[callout\](.*?)\[\/callout\].*?<\/p>(?:[^<>]*<p>.*?<\/p>){2}[^<]*\K"
test_str = ("<p>If you wanna improve yer German, don't try to read Heine or some elevated crap... watch old episodes of [callout]Tatort or Bukow & Konig[/callout].</p>\n"
"<p>If I were teaching a music appreciation I wouldn't teach Beethoven. I'd teach Stamitz and average composers.</p>\n"
"<p>And here is a 3rd paragraph.</p>\n"
"<p>And here is a 4th paragraph.</p>")
subst = "<blockquote class=\"pullquote\">\\1</blockquote>\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.