const regex = new RegExp('(?<AttributeName>(?:src|background))\\s*=\\s*["\\'](?<AttributeValue>(?:[^"\\'])*)', 'g')
const str = `<html>
<table id='tblTest' border="1">
<tr>
<td colspan="1" >CellA</td>
</tr>
<tr>
<td>Click<a href="http://mail.google.com" >here</a></td>
</tr>
<tr>
<td>
<img src="http://wcrustine.org/Portals/0/click_here_button.jpg" style="width:100px;height:100px;"></img></td>
</tr>
<tr>
<td background="https://ci6.googleuser.com/proxy/d-NpaBfbly5hKSic8pomfvI4scwJqkF2wwmRqEB4stR8jfO7jo-Sx-JcVLfIXqw5gJnd05Rl0aY3evT2DhmS6he85ifLGQA=s0-d-e1-ft#http://newsletter.mydomain.com/template/header_bg.jpg" bgcolor="#336699" height="100" style="background:url(https://ci5.googleuser.com/proxy/d-NpaBfbly5hKSic8pomfvI4scwJqkF2wwmRqEB4stR8jJrvfO7jo-Sx-JcVLfIgJnd05Rl0aY3evT2DhmS6LU85ifLGQA=s0-d-e1-ft#http://newsletter.mydomain.com/template/header_bg.jpg) top left repeat #336699" width="">
</td>
</tr>
</table>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}