# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<AttributeName>(?:src|background))\s*=\s*[\"'](?<AttributeValue>(?:[^\"'])*)"
test_str = ("<html>\n"
"<table id='tblTest' border=\"1\">\n"
"<tr>\n"
"<td colspan=\"1\" >CellA</td>\n"
"</tr>\n"
"<tr>\n"
"<td>Click<a href=\"http://mail.google.com\" >here</a></td>\n"
"</tr>\n"
"<tr>\n"
"<td>\n"
"<img src=\"http://wcrustine.org/Portals/0/click_here_button.jpg\" style=\"width:100px;height:100px;\"></img></td>\n"
"</tr>\n"
"<tr>\n"
"<td background=\"https://ci6.googleuser.com/proxy/d-NpaBfbly5hKSic8pomfvI4scwJqkF2wwmRqEB4stR8jfO7jo-Sx-JcVLfIXqw5gJnd05Rl0aY3evT2DhmS6he85ifLGQA=s0-d-e1-ft#http://newsletter.mydomain.com/template/header_bg.jpg\" bgcolor=\"#336699\" height=\"100\" style=\"background:url(https://ci5.googleuser.com/proxy/d-NpaBfbly5hKSic8pomfvI4scwJqkF2wwmRqEB4stR8jJrvfO7jo-Sx-JcVLfIgJnd05Rl0aY3evT2DhmS6LU85ifLGQA=s0-d-e1-ft#http://newsletter.mydomain.com/template/header_bg.jpg) top left repeat #336699\" width=\"\">\n"
" \n"
"</td>\n"
"</tr>\n"
"</table>\n"
"</html>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.