$re = '/(?mx)
( # the 1st capture group will contain this sequence
1 # this sequence should begin with 1
(?=(?:[01]{6,19}) # let\'s see that there are enough 0s and 1s in a line
(.*$)) # the 2nd capture group will contain all characters to the end of a line
(?:0*1){6}) # there must be six more 1s in the sequence
(?=.{0,13} # complement the 1st capture group to 20 characters
\2) # the rest of a line should be 2nd capture group/m';
$str = '0000000
101010101010111111100000000000001
00000001100000001110111100000000000000000000000000000000000000000000000000110000000111000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001100
1111111
111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);