# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?mx)\n"
r"( # the 1st capture group will contain this sequence\n"
r"1 # this sequence should begin with 1\n"
r"(?=(?:[01]{6,19}) # let's see that there are enough 0s and 1s in a line\n"
r" (.*$)) # the 2nd capture group will contain all characters to the end of a line\n"
r"(?:0*1){6}) # there must be six more 1s in the sequence\n"
r"(?=.{0,13} # complement the 1st capture group to 20 characters\n"
r"\2) # the rest of a line should be 2nd capture group")
test_str = ("0000000\n"
"101010101010111111100000000000001\n"
"00000001100000001110111100000000000000000000000000000000000000000000000000110000000111000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001100\n"
"1111111\n"
"111111")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.