#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)([\p{InHiragana}+|\p{InKatakana}+|\p{IsHan}+]+[県都府道])(.*)"
Local $sString = "〒100-0001 北海道千代田区千代田1−1−1" & @CRLF & _
"青森県" & @CRLF & _
"岩手県" & @CRLF & _
"宮城県" & @CRLF & _
"秋田県" & @CRLF & _
"山形県" & @CRLF & _
"福島県" & @CRLF & _
"茨城県" & @CRLF & _
"栃木県" & @CRLF & _
"群馬県" & @CRLF & _
"埼玉県" & @CRLF & _
"千葉県" & @CRLF & _
"東京都" & @CRLF & _
"神奈川県" & @CRLF & _
"新潟県" & @CRLF & _
"富山県" & @CRLF & _
"石川県" & @CRLF & _
"福井県" & @CRLF & _
"山梨県" & @CRLF & _
"長野県" & @CRLF & _
"岐阜県" & @CRLF & _
"静岡県" & @CRLF & _
"愛知県" & @CRLF & _
"三重県" & @CRLF & _
"滋賀県" & @CRLF & _
"京都府" & @CRLF & _
"大阪府" & @CRLF & _
"兵庫県" & @CRLF & _
"奈良県" & @CRLF & _
"和歌山県" & @CRLF & _
"鳥取県" & @CRLF & _
"島根県" & @CRLF & _
"岡山県" & @CRLF & _
"広島県" & @CRLF & _
"山口県" & @CRLF & _
"徳島県" & @CRLF & _
"香川県" & @CRLF & _
"愛媛県" & @CRLF & _
"高知県" & @CRLF & _
"福岡県" & @CRLF & _
"佐賀県" & @CRLF & _
"長崎県" & @CRLF & _
"熊本県" & @CRLF & _
"大分県" & @CRLF & _
"宮崎県" & @CRLF & _
"鹿児島県" & @CRLF & _
"沖縄県"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")