# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\p{InHiragana}+|\p{InKatakana}+|\p{IsHan}+]+[県都府道])(.*)"
test_str = ("〒100-0001 北海道千代田区千代田1−1−1\n"
"青森県\n"
"岩手県\n"
"宮城県\n"
"秋田県\n"
"山形県\n"
"福島県\n"
"茨城県\n"
"栃木県\n"
"群馬県\n"
"埼玉県\n"
"千葉県\n"
"東京都\n"
"神奈川県\n"
"新潟県\n"
"富山県\n"
"石川県\n"
"福井県\n"
"山梨県\n"
"長野県\n"
"岐阜県\n"
"静岡県\n"
"愛知県\n"
"三重県\n"
"滋賀県\n"
"京都府\n"
"大阪府\n"
"兵庫県\n"
"奈良県\n"
"和歌山県\n"
"鳥取県\n"
"島根県\n"
"岡山県\n"
"広島県\n"
"山口県\n"
"徳島県\n"
"香川県\n"
"愛媛県\n"
"高知県\n"
"福岡県\n"
"佐賀県\n"
"長崎県\n"
"熊本県\n"
"大分県\n"
"宮崎県\n"
"鹿児島県\n"
"沖縄県")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.