$re = '/(\d{3,6})[:|\s]?([a-z]{3}) ?
(
[^\r\n]+\d+$
|
[^\r\n]+(?=\d{6})
|
[^\r\n]+
)/xmi';
$str = '2805 wtr Verzekeren
2705 aja 2905 ophalen
290610 cwu Bezorgen bij klant 290610 tbi Verzekeren
290610 cwu Bezorgen bij klant 290610';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);