// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xmi)(\d{3,6})[:|\s]?([a-z]{3}) ?
(
[^\r\n]+\d+$
|
[^\r\n]+(?=\d{6})
|
[^\r\n]+
)").unwrap();
let string = "2805 wtr Verzekeren
2705 aja 2905 ophalen
290610 cwu Bezorgen bij klant 290610 tbi Verzekeren
290610 cwu Bezorgen bij klant 290610";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}