const regex = new RegExp('(?<=\\[)(?:[^\\'\\]]*\\')?([^\\'\\]]+)', 'g')
const str = `Something bad happened! @ data[u'string_1'][u'string_2']['u2'][0]['u2']`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}