re = /(?<=\[)(?:[^'\]]*')?([^'\]]+)/
str = 'Something bad happened! @ data[u\'string_1\'][u\'string_2\'][\'u2\'][0][\'u2\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end