$re = '/\b(ah|kh|qh|3c|2c)\b/';
$str = 'ah
yeah
kha
kh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);