# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!St\.|Mrs?\.|Jr\.|Dr\.|Sr\.|Prof\.)(\b\S+[.?!]["']?)\s/$1\n/g;t' <<< "I works just fine for my purpose, but now I need the exact same regex in Javascript? (to make sure that the outputs are consistent) and I'm struggling to translate Mr. this Python regex. Into one compatible with Javascript. \"What with Quoting?\" Another sentence. And St. CommuniSt. gfdg
"