const regex = /(?!St\.|Mrs?\.|Jr\.|Dr\.|Sr\.|Prof\.)(\b\S+[.?!]["']?)\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!St\\.|Mrs?\\.|Jr\\.|Dr\\.|Sr\\.|Prof\\.)(\\b\\S+[.?!]["\']?)\\s', 'g')
const str = `I works just fine for my purpose, but now I need the exact same regex in Javascript? (to make sure that the outputs are consistent) and I'm struggling to translate Mr. this Python regex. Into one compatible with Javascript. "What with Quoting?" Another sentence. And St. CommuniSt. gfdg
`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);