$re = '/^[a-zA-Z\s]*/m';
$str = 'This is a test
This is another test 843 text
123Number start
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);