re = /^[a-zA-Z\s]*/m
str = 'This is a test
This is another test 843 text
123Number start
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end