#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-g?(gdb)?(lldb)?([1-9])?$"
Local $sString = "-g" & @CRLF & _
"-g3" & @CRLF & _
"-ggdb" & @CRLF & _
"-ggdb3" & @CRLF & _
"-glldb" & @CRLF & _
"-glldb3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")