$re = '/-g?(gdb)?(lldb)?([1-9])?$/m';
$str = '-g
-g3
-ggdb
-ggdb3
-glldb
-glldb3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);