re = /^[^\s,]+(?:,\s*[^\s,]+)*$/m
str = 'foo-bar, hey_friend, 56-8, 7_88, elephant$n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end