package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(0{3,}|\W+)`)
var str = `5067/33177
506700000033442
5067…34142
5067-33304`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}