$re = '/(?:\'[-!@#$%^&*()\w\s]+\')|(?:empty\(\))|(?:notempty\(\))|(?:currentdate\(\))|(?:and)|(?:or)|(?:not)|([-!@#$%^&*()\w]+)/i';
$str = '\'This is not captured\' but this is and not or empty() notempty() currentdate() capture';
$subst = "'$1'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;