import Foundation
let pattern = ##"(?:'[-!@#$%^&*()\w\s]+')|(?:empty\(\))|(?:notempty\(\))|(?:currentdate\(\))|(?:and)|(?:or)|(?:not)|([-!@#$%^&*()\w]+)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"'This is not captured' but this is and not or empty() notempty() currentdate() capture"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'$1'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)