package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:'[^']*'|(?:\b(?:(?:not)?empty|currentdate)\(\)|and|or|not))|([!@#$%^&*_.\w-]+)`)
var str = `'This is not captured' but this is and not or empty() notempty() currentdate() capture`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}