$re = '/(?:\'[^\']*\'|(?:\b(?:(?:not)?empty|currentdate)\(\)|and|or|not))|([!@#$%^&*_.\w-]+)/i';
$str = '\'This is not captured\' but this is and not or empty() notempty() currentdate() capture';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);