$re = '/^\/(?:\/|\*).*/m';
$str = '<script>
// This is a comment
/* This is another comment */
// The following is not a comment
var src="//google.com";
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);