// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/(?:\/|\*).*").unwrap();
let string = "<script>
// This is a comment
/* This is another comment */
// The following is not a comment
var src=\"//google.com\";
</script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}