re = /(\w{2})\w*\1/
str = 'The dodo was one of the sturdiest birds. An educated termite may learn how to operate a phonograph, but it\'s unlikely. I sense that an amalgam that includes magma will enlighten Papa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end