using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\ba(?:(?!bad).){1,250}?z\b";
string input = @"avgxfz
agfdbadhgz
abadz
acbadccz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}