$re = '/\ba(?:(?!bad).){1,250}?z\b/m';
$str = 'avgxfz
agfdbadhgz
abadz
acbadccz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);