const regex = /\| *\{\{cal\|([a-z]*)\}\}.*\{\{dm\|([a-z 0-9|]*)\}\} *\|\|(.*) *, *(.*) *, *(.*) *\{\{SmallFlag\|(.*)\}\}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\| *\\{\\{cal\\|([a-z]*)\\}\\}.*\\{\\{dm\\|([a-z 0-9|]*)\\}\\} *\\|\\|(.*) *, *(.*) *, *(.*) *\\{\\{SmallFlag\\|(.*)\\}\\}', 'gi')
const str = `\\| {{cal|social}} || {{dm|mar 1}} || Description with Wiki or HTML Link, TOWN, COUNTRY {{SmallFlag|flag}}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}