re = /\| *\{\{cal\|([a-z]*)\}\}.*\{\{dm\|([a-z 0-9|]*)\}\} *\|\|(.*) *, *(.*) *, *(.*) *\{\{SmallFlag\|(.*)\}\}/i
str = '\\| {{cal|social}} || {{dm|mar 1}} || Description with Wiki or HTML Link, TOWN, COUNTRY {{SmallFlag|flag}}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end