import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:.*?\\b(apple|orange)\\b)?)(.*?\\bHORSE\\b)(?(1)(?2))";
final String string = "foo bar\n"
+ "apple HORSE\n"
+ "foo bar HORSE\n"
+ "apple HORSE HORSE\n"
+ "HORSE foo orange HORSE bar\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}