$re = '/^(?=(?:.*?\b(apple|orange)\b)?)(.*?\bHORSE\b)(?(1)(?2))/m';
$str = 'foo bar
apple HORSE
foo bar HORSE
apple HORSE HORSE
HORSE foo orange HORSE bar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);