using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""SenderAddress"":""\w+.*@(?<s_domain>.*)"",""RecipientAddress"":""\w+.*@(?<r_domain>\S+)\w+";
string input = @"{""EventReceivedTime"":""2019-06-26 09:47:53"",""SourceModuleName"":""EXCHGETMESGTRACEPRD"",""SourceModuleType"":""im_file"",""MessageId"":""<0100016b93ffa54d-a8a96a78-94b0-46e6-aed6-c0e82ef6d228-000000@email.amazonses.com>"",""Received"":""6/26/2019 9:35:33 AM"",""SenderAddress"":""DoNotReply@ConnectedCommunity.org"",""RecipientAddress"":""jfz5@blah.edu"",""Status"":""Delivered"",""Size"":""0""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}