import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"SenderAddress\":\"\\w+.*@(?<s_domain>.*)\",\"RecipientAddress\":\"\\w+.*@(?<r_domain>\\S+)\\w+";
final String string = "{\"EventReceivedTime\":\"2019-06-26 09:47:53\",\"SourceModuleName\":\"EXCHGETMESGTRACEPRD\",\"SourceModuleType\":\"im_file\",\"MessageId\":\"<0100016b93ffa54d-a8a96a78-94b0-46e6-aed6-c0e82ef6d228-000000@email.amazonses.com>\",\"Received\":\"6/26/2019 9:35:33 AM\",\"SenderAddress\":\"DoNotReply@ConnectedCommunity.org\",\"RecipientAddress\":\"jfz5@blah.edu\",\"Status\":\"Delivered\",\"Size\":\"0\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}