package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((([1-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])[.]){3}([1-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5]))?$`)
var str = `12.22.34.56
12223456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}