re = /^((([1-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])[.]){3}([1-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5]))?$/m
str = '12.22.34.56
12223456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end