$re = '/(?<=(<\/))(.+)(>)/i';
$str = '<script type="text/javascript">
inner_text_1
<c:set var="" value="">inner_text_2</c:set>
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);