$re = '/(?=((((\b\S+)(?: \S+)?)(?: \S+)?)(?: \S+)?))/';
$str = 'AA BB CC DD EE FF GG HH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);