re = /(?=((((\b\S+)(?: \S+)?)(?: \S+)?)(?: \S+)?))/
str = 'AA BB CC DD EE FF GG HH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end