const regex = /^([\d.]+) ((?:[^.]|\.(?!\.))+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\d.]+) ((?:[^.]|\\.(?!\\.))+)', 'gm')
const str = `1.6.1 Members................................................................ 12
1.6.2 Accessibility.......................................................... 13
1.6.3 Type parameters........................................................ 13
1.6.4 The T generic type aka <T>............................................. 13
1.6.1 The .net 4.5 framework...........`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}