$re = '/^([\d.]+) ((?:[^.]|\.(?!\.))+)/m';
$str = '1.6.1 Members................................................................ 12
1.6.2 Accessibility.......................................................... 13
1.6.3 Type parameters........................................................ 13
1.6.4 The T generic type aka <T>............................................. 13
1.6.1 The .net 4.5 framework...........';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);