package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:cpp|h)\b`)
var str = `cpp h cph`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}