#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:http?s?:\/\/)?(?:www.)?(?:m.)?(?:music.)?youtu(?:\.?be)(?:\.com)?(?:(?:\w*.?:\/\/)?\w*.?\w*-?.?\w*\/(?:embed|e|v|watch|.*\/)?\??(?:feature=\w*\.?\w*)?&?(?:v=)?\/?)([\w\d_-]{11})(?:\S+)?"
Local $sString = "https://www.youtube.com/watch?v=RCGGG9piAGY asdfasdfsadfsdf" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related" & @CRLF & _
"http://youtu.be/iwGFalTRHDA" & @CRLF & _
"http://youtu.be/n17B_uFF4cA" & @CRLF & _
"http://www.youtube.com/embed/watch?feature=player_embedded&v=r5nB9u4jjy4" & @CRLF & _
"http://www.youtube.com/watch?v=t-ZRX8984sc" & @CRLF & _
"http://youtu.be/t-ZRX8984sc" & @CRLF & _
"https://www.youtube.com/attribution_link?a=tolCzpA7CrY&u=%2Fwatch%3Fv%3DMoBL33GT9S8%26feature%3Dshare" & @CRLF & _
"https://www.youtube.com/watch?v=MoBL33GT9S8&feature=share" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA " & @CRLF & _
"https://www.youtube.com/watch?v=iwGFalTRHDA " & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related " & @CRLF & _
"http://youtu.be/iwGFalTRHDA " & @CRLF & _
"http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/embed/watch?v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/embed/v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"www.youtube.com/watch?v=iwGFalTRHDA " & @CRLF & _
"www.youtu.be/iwGFalTRHDA " & @CRLF & _
"youtu.be/iwGFalTRHDA " & @CRLF & _
"youtube.com/watch?v=iwGFalTRHDA " & @CRLF & _
"http://www.youtube.com/watch/iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/v/iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/v/i_GFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related " & @CRLF & _
"http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA" & @CRLF & _
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail" & @CRLF & _
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtu/v/i_GFalTRHDA" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=RCGGG9piAGYUt Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.https://www.youtube.com/watch?v=RCGGG9piAGYUt enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillumdolore eu fugiat nulla pariatur.https://i.stack.imgur.com//VFMIw.jpg?s=128\u0026g=1\u0026g\u0026s=32Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")