# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:http?s?:\/\/)?(?:www.)?(?:m.)?(?:music.)?youtu(?:\.?be)(?:\.com)?(?:(?:\w*.?:\/\/)?\w*.?\w*-?.?\w*\/(?:embed|e|v|watch|.*\/)?\??(?:feature=\w*\.?\w*)?&?(?:v=)?\/?)([\w\d_-]{11})(?:\S+)?"
test_str = ("https://www.youtube.com/watch?v=RCGGG9piAGY asdfasdfsadfsdf\n"
"http://www.youtube.com/watch?v=iwGFalTRHDA\n"
"http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related\n"
"http://youtu.be/iwGFalTRHDA\n"
"http://youtu.be/n17B_uFF4cA\n"
"http://www.youtube.com/embed/watch?feature=player_embedded&v=r5nB9u4jjy4\n"
"http://www.youtube.com/watch?v=t-ZRX8984sc\n"
"http://youtu.be/t-ZRX8984sc\n"
"https://www.youtube.com/attribution_link?a=tolCzpA7CrY&u=%2Fwatch%3Fv%3DMoBL33GT9S8%26feature%3Dshare\n"
"https://www.youtube.com/watch?v=MoBL33GT9S8&feature=share\n"
"http://www.youtube.com/watch?v=iwGFalTRHDA \n"
"https://www.youtube.com/watch?v=iwGFalTRHDA \n"
"http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related \n"
"http://youtu.be/iwGFalTRHDA \n"
"http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA\n"
"http://www.youtube.com/embed/watch?v=iwGFalTRHDA\n"
"http://www.youtube.com/embed/v=iwGFalTRHDA\n"
"http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA\n"
"http://www.youtube.com/watch?v=iwGFalTRHDA\n"
"www.youtube.com/watch?v=iwGFalTRHDA \n"
"www.youtu.be/iwGFalTRHDA \n"
"youtu.be/iwGFalTRHDA \n"
"youtube.com/watch?v=iwGFalTRHDA \n"
"http://www.youtube.com/watch/iwGFalTRHDA\n"
"http://www.youtube.com/v/iwGFalTRHDA\n"
"http://www.youtube.com/v/i_GFalTRHDA\n"
"http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related \n"
"http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA\n"
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail\n"
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ\n\n"
"http://www.youtu/v/i_GFalTRHDA\n\n"
"https://www.youtube.com/watch?v=RCGGG9piAGYUt Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.https://www.youtube.com/watch?v=RCGGG9piAGYUt enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillumdolore eu fugiat nulla pariatur.https://i.stack.imgur.com//VFMIw.jpg?s=128\\u0026g=1\\u0026g\\u0026s=32Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.