#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".+(?=(?:AN|N)-\d+)|(?<=(?:AN|N)-\d+)\s.+"
Local $sString = "2 BILLING ID AN-19 RPS Ex : “00411850177 “" & @CRLF & _
"3 FILLER AN-11 RPS EX: “ “" & @CRLF & _
"4 FILLER AN-15 RPS EX: “ “" & @CRLF & _
"5 FILLER AN-30 RPS EX: “ “" & @CRLF & _
"6 FILLER AN-2 RPS EX: “ “" & @CRLF & _
"7 FILLER AN-1 RPS EX: “ “" & @CRLF & _
"8 BILLER CODE AN-4 RPS Ex : “1310” 1302 means PDAM Mitracom" & @CRLF & _
"9 FILLER AN-11 RPS EX: “ “" & @CRLF & _
"10 ADMIN FEE N-12 LPZ Ex : “000000075000”" & @CRLF & _
" 11 FILLER AN-11 RPS EX: “ “" & @CRLF & _
"12 FILLER AN-12 RPS EX: “ “ "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)