import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(?=(?:AN|N)-\\d+)|(?<=(?:AN|N)-\\d+)\\s.+";
final String string = "2 BILLING ID AN-19 RPS Ex : “00411850177 “\n"
+ "3 FILLER AN-11 RPS EX: “ “\n"
+ "4 FILLER AN-15 RPS EX: “ “\n"
+ "5 FILLER AN-30 RPS EX: “ “\n"
+ "6 FILLER AN-2 RPS EX: “ “\n"
+ "7 FILLER AN-1 RPS EX: “ “\n"
+ "8 BILLER CODE AN-4 RPS Ex : “1310” 1302 means PDAM Mitracom\n"
+ "9 FILLER AN-11 RPS EX: “ “\n"
+ "10 ADMIN FEE N-12 LPZ Ex : “000000075000”\n"
+ " 11 FILLER AN-11 RPS EX: “ “\n"
+ "12 FILLER AN-12 RPS EX: “ “ ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}